CONHECENDO O VISUAL STuDIO .NET

Nesta matéria estaremos apresentando a IDE (Integrated
Development Environment) do Visual Studio .NET. A Microsoft incluiu
nesta versao da ferramenta de desenvolvimento todos os conceitos que ja
vinha procurando aplicar e alguns novos conceitos visando o RAD (rapid
application development).

A IDE é a mesma para todas as linguagens do Visual Studio .NET.
Algumas modificacoes de valores para propriedades de projetos e
configuracgoes de build podem ocorrer, mas vocé contara com o mesmo
arsenal de palhetas e janelas em qualquer linguagem que vocé estiver
utilizando para desenvolver uma aplicacdo, ou seja, a mesma interface
para projetos em Visual Basic ou C#.

Gerenciando o ambiente de desenvolvimento

O ambiente de desenvolvimento do Visual Studio .NET (IDE) é
composto por inimeras janelas ou caixas com recursos para auxiliad-lo no
desenvolvimento rapido de aplicativos. Essas janelas se enquadram em
duas categorias basicas: janelas de ferramentas’ e janelas de documentos’.
As janelas de ferramentas sao listadas no menu View, sendo que muitas
outras encontram-se no seu sub-menu Other Windows. Algumas dessas
janelas de ferramentas sdao: Solution Explorer, Toolbox e Properties.

Ja as janelas de documentos s3o criadas dinamicamente quando
abrimos ou quando criamos arquivos ou outros itens. A lista de janelas de
documento abertas aparece no menu Window na mesma ordem em que se
encontram no ambiente de desenvolvimento, sendo a janela em primeiro
plano na tela listada primeiro. Algumas janelas de documentos sao o Code
Editor e o Form Designer.



Forml.cs [Design] | Forml.cs

Na imagem anterior, a janela Form1.cs seria a janela de documento
“Form Design” e a janela Formzi.cs seria o “Code Editor”.

E interessante observar que vocé pode escolher entre dois modos de
trabalhar com as janelas de documentos: o novo modo “com abas”, no qual
as janelas exibem abas na parte superior para serem selecionadas (como
na imagem anterior) e o modo MDI, antigo conhecido, no qual a janela em
primeiro plano, quando maximizada, apresenta os botdes Minimizar,
Restaurar e Fechar no canto superior esquerdo do ambiente de
desenvolvimento, logo abaixo da barra de titulos do mesmo.

Inicialmente, o Visual Studio .NET vem configurado para exibir as
janelas no modo “com abas”, mas vocé pode mudar para o modo MDI
selecionando a opcao Options no menu Tools e definindo a opcao MDI
Environment na op¢ao General da pasta Environment.
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Como as janelas sao muitas, foram implementados alguns
excelentes recursos de gerenciamento de janelas. Por exemplo, as janelas
de ferramentas podem ser arranjadas no IDE para aparecerem e
desaparecerem automaticamente, ficarem ligadas a outras janelas de
ferramentas com abas para selecao, “ancorarem” nas extremidades da IDE
ou de outras janelas, flutuarem sobre o IDE, se comportarem como
janelas-filha MDI ou até serem exibidas em outro monitor. Vocé pode
posicionar essas janelas arrastando-as com o mouse e observando seu
comportamento.

Todas as janelas de ferramentas do IDE podem assumir trés tipos
de comportamento: Docktable (ancoravel), Floating (flutuante) e MDI
(Multiple Document Interface — Interface de Documentos Multiplos). Para
definir qual deve ser o comportamento de uma determinada janela, basta
seleciona-la e ativar ou desativar, no menu Window, op¢oes Docktable e
Floating. Com a opcao Docktable ativa, a janela podera ser ancorada na
borda do IDE ou em outras janelas Docktable. Com a op¢ao. Com a opcao
Floating ativa, a janela ficara flutuando sobre o ambiente, e com as opcoes
Floating e Docktable desativadas, ela se comporta como uma janela-filha
MDI, podendo ser arranjada lado a lado horizontal, ou verticalmente em
relacdo as outras janelas MDI, minimizada ou maximizada dentro do IDE.
Como se pode notar, hd uma enorme flexibilidade no modo como podemos
gerenciar nossas janelas. Mas isto ndo é tudo!

Quando a janela esta definida como Docktable e ancorada no IDE,
ela também se torna passivel de ser Auto Hide, ou auto-ocultavel. Vocé
vera em sua barra de titulo um icone de alfinete ( & ). Este alfinete permite
que voce ative ou desative a ocultacdo automatica da janela. Quando vocé




da um clique no icone do alfinete de uma janela que esta em exibicao, ela
sera escondida logo que voce tirar o mouse de cima da mesma, ficando
uma guia (ou paleta) na borda da tela com o nome da janela oculta.
Passando o mouse sobre esta guia, a janela sera exibida novamente e se
vocé quiser deixa-la fixa na tela, basta dar um clique sobre o alfinete
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Qualquer que seja 0 modo de exibicao de uma janela, vocé pode
oculta-la definitivamente dando um clique no “X” que existe no seu canto
superior direito. Depois, para re-exibir a janela, vocé deve seleciona-la no
menu View do IDE. Nos proximos topicos conheceremos especificamente
algumas dessas janelas.

Conhecendo as janelas do ambiente de

desenvolvimento
Agora que vocé ja sabe como gerenciar as janelas do IDE, vamos dar
uma olhada mais de perto em algumas delas.



Janela Solution Explorer

Todos os projetos criados dentro do Visual Studio .NET ficam
dentro de uma solucao. O Solution Explorer é uma interface simples entre
vocé e sua solucao. Ele lhe d4 informacoes em tempo real sobre itens da
solucdo e permite administrar esses itens visualmente. Por exemplo, vocé
pode monitorar os estados atuais de arquivos-fonte gerenciados, arrastar
itens de um projeto para outro e visualizar as propriedades da solucao, de
um projeto ou de um arquivo. Muitas das tarefas mais comuns
relacionadas com a manutencao de arquivos e projetos podem ser
realizados por meio do Solution Explorer.
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O Solution Explorer tem uma barra de ferramentas que pode exibir
alguns icones de acordo com o item que vocé seleciona sua arvore. Por
exemplo, se voce seleciona um Form, tal como o Form1.cs do nosso
projeto, serdo exibidos cinco icones com as seguintes finalidades.

=l'View Code: Abre o arquivo selecionado para edicao no Code
Editor;

= View Designer: Abre o arquivo no Forms Designer para
visualizagao e alteracao;

"] Refresh: Atualiza a exibicao do item selecionado no Solution
Explorer. Este botao também pega a tltima versao de um arquivo que esta
sendo usado por outros programadores em modo compartilhado de rede.

=¥ Show All Files: Exibe todas as pastas e arquivos da Solucao,
incluindo aqueles que foram excluidos do projeto atual e os que estao
ocultos.

Properties: Exibe na janela Properties as propriedades do item
selecionado no Solution Explorer



Janela Toolbox

A janela Toolbox (ou “Caixa de Ferramentas”) pode ser aberta pelo
menu View > Toolbox. E ela que comporta os controles (componentes) que
podem ser inseridos nos projetos. Esta janela contém varias abas que
podem ser estendidas com um clique do mouse. Outras abas também
podem aparecer dinamicamente de acordo com o tipo de projeto em que
voce esté trabalhando.
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Windows Forms |ﬂ
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Para utilizar esta janela, basta clicar no componente desejado e
clicar depois em algum lugar dentro do form. Desta forma se o
componente for visual, aparecera na regiao do form que acabou de clicar.

Janela Properties

A janela Properties (ou “Propriedades”) pode ser acessada por meio
do menu View > Properties Window. Algumas propriedades possuem o
simbolo de mais (“+”), pois estdo agrupadas em categorias. Clicando sobre
este sinal vocé pode acessar a lista de propriedades que compbem estas
categorias.

Quando voceé escolhe um componente e coloca-o em seu form, é
nesta janela que vocé deve configurar os valores iniciais das propriedades
deste componente. Por exemplo, o proprio form que vocé utiliza
obrigatoriamente em um projeto do tipo WinForms, se vocé deseja alterar
o titulo do mesmo, basta ir na janela properties e alterar a propriedade
“Text”, colocando o titulo desejado. Veja a imagem a seguir:



=
I Form1 System.Windows,Forms,Form j
=B ElEd
MaximumSize 0,0 -
Menu (none)
MinimizeBox True
MinimumsSize 0,0
Opacity 100%
RightTolLeft Mo
ShowInTaskbar True
Size 592, 408
SizeGripstyle Auto
SnapToGrid True
StartPosition WindowsDefaultLocati
Tag
Text Forml
TopMost False i
T b o 1 hd
Text
The text contained in the control.

Alterando a propriedade “Text” conforme sugere a imagem, a
palavra Form1 ndo mais ir4 aparecer no titulo do seu form.

Janela OutPut

A janela OutPut (ou “Saida de Informacoes”) é acessivel pelo menu
View > Other Windows > OutPut. Como o proprio nome diz, esta janela
exibe as saidas de informac6es do ambiente de desenvolvimento do Visual
Studio .NET.

Durante o processo de compilacao, por exemplo, o Visual
Studio.NET coloca informacoes de cada etapa do procedimento que esta
sendo executado. Vocé também pode forcar uma saida de informacoes
nesta janela utilizando o método WriteLine( ) do objeto Debug.
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| Build |

—————— Build sterted: Project: ExemploP00, Configurstion: Debug .NET ————— -

Preparing resources. ..

Updating references. ..

Performing main compilation.__

Build complete —— 0 errors, 0 warnings

Building satellite assemblies. ..

—————————————————————— Done —————————————————————— b

Build: 1 succeeded, 0 failed, 0 skipped -

dl | _'IJ
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Janela Object Browser

A janela Object Browser (ou “Navegador de Objetos”) é aberta pelo
menu View > Other Windows > Object Browser. Ela apresenta a estrutura
hierarquica de cada objeto disponivel, bem como a lista de membros
pertencentes a cada objeto selecionado. Os objetos sdo apresentados na
caixa Objects em uma estrutura de arvore, com “n6s” que podem ser
expandidos ou compactados por meio de um clique em seu sinal de adicao
(+) ou subtracao (-). Isso nos da uma visao bem ampla dos recursos
contidos em cada objeto.

Devido ao suporte aprimorado da orientacao a objetos, a janela
Object Browser também foi melhorada para mostrar todos os detalhes dos
objetos. Selecionando um objeto na caixa Objects desta janela, vocé podera
ver os membros desse objeto na caixa Members e uma descricao do
mesmo na parte inferior da janela. E interessante também que nesta janela
vocé pode ver o nome da assembly (DLL) onde estao contidos certos
recursos, e até o caminho dessa assembly em seu computador.
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public class Arraylist : System.0Object
Member of System.Collections

Summary:
Implements the System.Collections.IList interface using an array whose size is dynamically increased as required.

Janela Class View

A janela Class View (ou “Visualizador de Classes”) é mais uma
implementacao visando facilitar o trabalho com o modelo de programacao
orientada a objetos e pode ser acessada através do menu View > Class
View.

Por meio desta janela, vocé pode ver toda a estrutura de classes
existente em seu projeto. Clicando duas vezes com o mouse em cima de
meétodo (item representado por uma caixa em rosa), o code editor é aberto
automaticamente e o cursor de edicao de texto é disponibilizado na
primeira linha do c6digo do método.

Conforme vocé vai notar na imagem seguinte, os métodos publicos
sao representados pela imagem de uma caixa rosa, os métodos privados
sao representados pela caixa rosa e um cadeado, os métodos protegidos
sao representados por uma caixa rosa e uma chave e finalmente os
métodos internos a classe sao representados por uma caixa rosa com um
envelope de carta em amarelo.
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Janela Web Browser

A janela Web Browser (ou “Navegador de Internet”) é um
navegador Web disponivel dentro do IDE do Visual Studio .NET.
Normalmente, quando vocé inicia o Visual Studio .NET, a janela Web
Browser aparece exibindo a sua pagina inicial, a Visual Studio Start
Page.Toda vez que uma janela WebBrowser € exibida, a barra de
ferramentas Web também aparece permitindo acesso rapido aos recursos
de navegacao pela Internet. Para acessa-la, vocé deve apontar o menu
View > Web Browser > Show Browser.

Start Page
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Vocé pode configurar qual pagina deseja que apareca inicialmente
quando o Visual Studio.NET é ativado no menu Tools > Options >
Enviroment > General, conforme a imagem a seguir.
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Janela Favorites

A janela Favorites (ou “Favoritos™) exibe a lista dos sites apontados
nos favoritos do seu navegador Internet Explorer, permitindo que vocé
adicione novos enderecos a essa lista, ou até a organize. Essas opcoes sao
disponibilizadas por meio de View > Other Windows > Favorites.

Janela Server Explorer

O Server Explorer (ou “Explorador de Servidores”) é um
gerenciador de servidores do Visual Studio .NET. Ele apresenta uma lista
com as conexoes de dados e todos os servidores disponiveis em sua rede.
Com ele vocé pode examinar e manipular os servidores de bancos de
dados, bem como os dados que estes contém. Vocé pode, por exemplo,
usa-lo para se conectar a uma base de dados para um Form de sua
aplicacdo, para um diagrama de banco de dados ou para uma consulta
SQL.

A janela Server Explorer pode ser acessada pelo menu View >
Server Explorer.
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Além de permitir facilmente a visualizagao de tabelas, views e
stored procedures, vocé também tem acesso ao event logs (do Event
Viewer), a filas MSMQ, Services e ao Performance Monitor entre outros.

Nota do Autor: Estes itens s6 poderam ser visualizados se vocé estiver desenvolvendo
em uma maquina instalada com o sistema operacional Windows 2000 Server ou
Advanced Server.

Macro Explorer

O Visual Studio .NET possui agora suporte a macros, para agilizar a
execucao de tarefas repetitivas, como ocorre com aplicativos como o
Microsoft Word e Excel.

A janela Macro Explorer (ou “Explorador de Macros”) lista todas as
macros disponiveis no ambiente e é sua ferramenta principal para ver e
executar macros. Para acessar esta janela vocé deve apontar para View >
Other Windows > MacroExplorer.
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Task List

A janela Task List (ou “Lista de Tarefas”) ajuda vocé a organizar e
administrar o trabalho de construir sua solucao. Excelente habito para
desenvolvimentos muito extensos, aonde vocé deixa algumas tarefas para
serem ajustadas depois com o objetivo de nao atrasar o cronograma.

Para exibi-la selecione a op¢ao Show Tasks no menu View e entao
escolha a categoria da mensagem que deseja ver, ou selecione Other
Windows no menu View e escolha Task List.

Task List - 2 User-defined tasks shown (f A
I | || Descripkion
Click here to add a new task

@ [ Terminar validag8o da ratina CPF

al |
I Task List | Bl output |% Indesx Results |

Vocé também pode configurar qual o tipo de informacao que deseja
apresentar nesta janela. Para fazer isto, clique com o botao direito do
mouse e selecione no menu que ira surgir o tipo de informacao desejada.
Na imagem anterior de exemplo, estamos visualizando “User defined
tasks”. A opc¢ao default desta janela é “Build Errors”.
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A janela Command Window (ou “Janela de Comando”) tem dois
modos diferentes: Comando e Imediato.

O modo Comando ¢é usado para executar rapidamente comandos
diretamente no ambiente Visual Studio .NET, evitando o sistema de
menus, ou para executar comandos que nao aparecem em qualquer menu.

Ja o Modo Imediato é usado para propésitos de depuracao e é igual
ao das versoes anteriores do Visual Studio.

Para acessar esta janela, aponte o menu View > Other Windows >
Command Window.

Command Window k|
*¥{ = HNothing -
Command "X" is not walid.

1| | 5

Criando Aplicacoes baseados em Templates

O Visual Studio .NET possue dezenas de templates que facilitam
muito no desenvolvimento de aplicativos. Para acessa-los, clique sobre o
menu File > New > Project.

Por exemplo, se vocé deseja construir uma aplicacao do tipo
WindowsForm, o Visual Studio.NET parte do pressuposto que pelo menos
um form devera existir em sua solucao e ele traz isto definido para vocé.
Voceé nao precisa se preocupar em adicionar o Main form ou escrever a
estrutura de seu c6digo (como a namespace e a classe principal que vai
conter o método estatico Main( );).
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Como pode observar na imagem anterior, existem varios templates
disponiveis nas linguagens que vocé possue em seu Visual Studio.NET.
Imagine a facilidade de criar um Web Services ou Mébile Web App através
destes templates. Basta selecioné-lo e toda a tarefa “pesada” como
declaracoes e diretivas de compilacao especificas ja estao prontas.

Crie um projeto qualquer e note que existe uma grande quantidade
de codigo ja escrita bem como indicacoes (em comentarios) de como o
cddigo pode ser colocado.

Esta é uma funcionalidade que promove um grande ganho de
produtividade para seu desenvolvimento.

Ocultamento do Texto

Este novo recurso nos permite ter uma visao hierarquica e resumida
de todo nosso codigo. Consiste numa funcionalidade do code editor em
colocar uma linha vertical do lado esquerdo do cédigo e, em pontos
especificos, como no inicio de func¢oes, classes, etc., inserir um sinal de
subtracao (ou adicao), indicando que aquela linha pode ser expandida ou
ocultada.

E possivel também ocultar e re-exibir qualquer bloco de codigo por
meio das op¢des disponiveis no sub-menu Outlining do menu Edit.
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= public class MainClass
{
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{
SETODO: Implementar o codigo do construtor
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private sString nome;
private int idade;

private decimal =salario:
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Com este recurso novo vocé pode muito bem minimizar regioes do
texto que nao estdo sendo trabalhadas em um determinado momento e se
preocupar com o que realmente é relevante para o momento. Para os
desenvolvedores que conhecem XML, € inevitavel a comparacao.

E, sem dtvida, um diferencial impressionante que fara vocé optar
pelo code editor do Visual Studio.NET em comparagao com qualquer
outro editor de textos.

Intellisense
O Intellisense é uma engenhosidade que lhe fornece uma lista de

facilidades enquanto digita o c6digo fonte no code editor do Visual
Studio.NET.

O Intellisense fornece as seguintes funcionalidades:

List Members (Lista de membros): Quando vocé digita o nome de um
objeto seguido de um ponto, o Intellisense abre uma caixa de listagem com
todos os membros deste objeto (propriedades, métodos, eventos, variaveis,
etc) e vocé podera escolher aquele que deseja usar. Auxilia na fixacao dos
nomes dos membros;
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E& Error
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& CpenstandardCutput

applic

Parameter Info (Informacoes de parametros): Quando vocé digita o
nome de uma funcao e abre parentes, o Intellisense exibe rapidamente a
lista de sobrecargas do método e a lista de parametros que cada sobrecarga
necessita;

public MainClass|()
i
SglConnection Cchn = new SqlCnnnectiDnil

" ~]of 2= SglConnection.SglConnection (string connectionString)
connecktionSkring:
The connection used ko open the SOL Server database,

Quick Info (Informacoes Rapidas): Quando vocé passa o mouse sobre
um especificador o Intellisense exibe a declaracao completa deste
especificador;

Complete Word (Completar palavra): Quando vocé esté digitando o
nome de um membro e pressiona CTRL + ESPACO, o Intellisense
completa a palavra (nome do membro) ou exibe uma lista de membros
com nomes que iniciam com as letras ja digitadas.

Obtendo Ajuda

O sistema de ajuda do Visual Studio.NET € a referéncia mais
completa sobre a ferramenta, seguida pelos manuais do usuario cedidos
juntos com o sistema.

Uma das funcionalidades mais interessantes que o Visual Studio
.NET possui é o Dynamic Help, que serve como uma espécie de ajudante
do programador. Sua tarefa é buscar informacoes e referéncias sobre o
objeto que vocé esta utilizando dinamicamente enquanto esta digitando o
codigo.
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O Help tradicional ativado a partir da tecla F1 também esta
presente na ferramenta de desenvolvimento.

Quando voce pressiona a tecla F1, o Visual Studio.NET nao procura
uma combinacao exata da palavra embaixo do cursor na lista Help Search.
Em vez disso, ele tenta adivinhar o que vocé esta precisando. Por exemplo,
se vocé pressionar F1 quando o cursor de texto estiver sobre a palavra
button1 no cédigo fonte, o sistema Help do Visual Studio.NET abrira
automaticamente a descricao da classe button, uma vez que é isto o que
provavelmente voceé esta procurando.

E interessante notar que no existe apenas um tnico arquivo Help
no Visual Studio.NET. Na maioria das vezes, vocé invocara o Help do
Visual Studio.NET, mas este arquivo é complementado pelo Help do
framework.

Estes arquivos de Help e outros relacionados com ferramentas
externas do Visual Studio.NET possuem um visual e um mecanismo de
procura que voce pode ativar pressionando o botao Help Topics enquanto
estiver no sistema de Help.



